# CVE-2010-0717: MoinMoin has improper default configuration

> Default configuration in MoinMoin fails to exclude unsafe package actions, potentially allowing unauthorized operations.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 26 Feb 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-5jjr-gmq3-f986, PYSEC-2010-3

## What is CVE-2010-0717?

CVE-2010-0717 is a high-severity vulnerability in n/a, published on 26 Feb 2010. It can be exploited over the network.

### Official description

The default configuration of cfg.packagepages_actions_excluded in MoinMoin before 1.8.7 does not prevent unsafe package actions, which has unspecified impact and attack vectors.

Weakness: CWE-16

## Which versions are affected by CVE-2010-0717?

3 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.8.7 |
| `moin` | PyPI | All versions | 1.8.7 |
| `moin` | PyPI | All versions | 1.8.7 |

Products: Moinmo Moinmoin.

## How do I fix CVE-2010-0717?

Upgrade moin to 1.8.7 or later.

## Is CVE-2010-0717 being exploited?

There is no known exploitation of CVE-2010-0717 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15275](https://insights.sbomify.com/CVE-2020-15275/): malicious SVG attachment causing stored XSS vulnerability in MoinMoin (high 8.7)
- [CVE-2009-4762](https://insights.sbomify.com/CVE-2009-4762/): MoinMoin Improper Access Control vulnerability (high 7.5)
- [CVE-2010-0669](https://insights.sbomify.com/CVE-2010-0669/): MoinMoin improper sanitizes user profiles (high 7.5)
- [CVE-2010-0668](https://insights.sbomify.com/CVE-2010-0668/): MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration (medium 6.8)
- [CVE-2008-6603](https://insights.sbomify.com/CVE-2008-6603/): MoinMoin Access Restrictions Bypassed due to improper ACL enforcement (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-0717 and fix it if it is affected.

What it is: CVE-2010-0717 is a high-severity vulnerability in n/a, published on 26 Feb 2010. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2010-0717 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.8.7
- moin (PyPI): affected all versions; fixed in 1.8.7
- moin (PyPI): affected all versions; fixed in 1.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-0717/ (Markdown: https://insights.sbomify.com/CVE-2010-0717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-0717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-0717
- OSV: https://osv.dev/vulnerability/CVE-2010-0717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-0717/
Summaries are generated and may contain mistakes; the official description above is the record.
