{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-openid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-10002 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp-module-openid to 1.0 or later.","what":"CVE-2010-10002 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openid, published on 1 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-10002 and fix it if it is affected.\n\nWhat it is: CVE-2010-10002 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openid, published on 1 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-10002 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp-module-openid (Packagist): affected all versions; fixed in 1.0\n- simplesamlphp/simplesamlphp-module-openid (Packagist): affected all versions; fixed in 1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-10002/ (Markdown: https://insights.sbomify.com/CVE-2010-10002/index.md)","id":"CVE-2010-10002","markdown":"https://insights.sbomify.com/CVE-2010-10002/index.md","name":"CVE-2010-10002","record":{"aliases":["GHSA-ggj9-6x8j-49w9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SimpleSAMLphp OpenID module","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts via the AuthState argument in the OpenID consumer template, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"simplesamlphp-module-openid","vendor":"simplesamlphp"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic has been found in SimpleSAMLphp simplesamlphp-module-openid. Affected is an unknown function of the file templates/consumer.php of the component OpenID Handler. The manipulation of the argument AuthState leads to cross site scripting. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0 is able to address this issue. The patch is identified as d652d41ccaf8c45d5707e741c0c5d82a2365a9a3. It is recommended to upgrade the affected component. VDB-217170 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SimpleSAMLphp simplesamlphp-module-openid OpenID consumer.php cross site scripting","id":"CVE-2010-10002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":2,"n_references":4,"next":{"headline":"gesellix titlelink plugin_content_title.php sql injection","id":"CVE-2010-10003"},"packages":[{"ecosystem":"Packagist","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-openid","purl":null,"source":"GHSA-ggj9-6x8j-49w9"},{"ecosystem":"Packagist","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-openid","purl":"pkg:composer/simplesamlphp/simplesamlphp-module-openid","source":"GHSA-ggj9-6x8j-49w9"}],"prev":{"headline":"Shemes GrabIt NZB Date Parser denial of service","id":"CVE-2010-10001"},"products":["simplesamlphp-module-openid"],"published":"2023-01-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["SimpleSAMLphp"]},"summary":"Remote attackers can execute arbitrary scripts via the AuthState argument in the OpenID consumer template, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2010-10002/"}