{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-infocard. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-10004 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp-module-infocard to 1.0 or later.","what":"CVE-2010-10004 is a low-severity cross-site scripting vulnerability in Information Cards Module, published on 9 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-10004 and fix it if it is affected.\n\nWhat it is: CVE-2010-10004 is a low-severity cross-site scripting vulnerability in Information Cards Module, published on 9 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-10004 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp-module-infocard (Packagist): affected all versions; fixed in 1.0\n- simplesamlphp/simplesamlphp-module-infocard (Packagist): affected all versions; fixed in 1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-10004/ (Markdown: https://insights.sbomify.com/CVE-2010-10004/index.md)","id":"CVE-2010-10004","markdown":"https://insights.sbomify.com/CVE-2010-10004/index.md","name":"CVE-2010-10004","record":{"aliases":["GHSA-2phw-rgr7-5pvh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"simpleSAMLphp module","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts in user browsers via the Information Cards Module in simpleSAMLphp.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"information_cards_module","vendor":"simplesamlphp"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Information Cards Module on simpleSAMLphp and classified as problematic. This issue affects some unknown processing. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.0 is able to address this issue. The identifier of the patch is f6bfea49ae16dc6e179df8306d39c3694f1ef186. It is recommended to upgrade the affected component. The identifier VDB-217661 was assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information Cards Module cross site scripting","id":"CVE-2010-10004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":2,"n_references":4,"next":{"headline":"michaelliao jopenid OpenIdManager.java getAuthentication timing discrepancy","id":"CVE-2010-10006"},"packages":[{"ecosystem":"Packagist","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-infocard","purl":null,"source":"GHSA-2phw-rgr7-5pvh"},{"ecosystem":"Packagist","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-infocard","purl":"pkg:composer/simplesamlphp/simplesamlphp-module-infocard","source":"GHSA-2phw-rgr7-5pvh"}],"prev":{"headline":"gesellix titlelink plugin_content_title.php sql injection","id":"CVE-2010-10003"},"products":["Information Cards Module"],"published":"2023-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts in user browsers via the Information Cards Module in simpleSAMLphp.","url":"https://insights.sbomify.com/CVE-2010-10004/"}