{"answers":{"affected":"2 open source packages ship an affected version, including org.expressme:JOpenId. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-10006 in the wild and no public exploit code.","fix":"Upgrade org.expressme:JOpenId to 1.08 or later.","what":"CVE-2010-10006 is a low-severity vulnerability in michaelliao jopenid, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-10006 and fix it if it is affected.\n\nWhat it is: CVE-2010-10006 is a low-severity vulnerability in michaelliao jopenid, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-10006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.expressme:JOpenId (Maven): affected all versions; fixed in 1.08\n- org.expressme:JOpenId (Maven): affected all versions; fixed in 1.08\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-10006/ (Markdown: https://insights.sbomify.com/CVE-2010-10006/index.md)","id":"CVE-2010-10006","markdown":"https://insights.sbomify.com/CVE-2010-10006/index.md","name":"CVE-2010-10006","record":{"aliases":["GHSA-m4f8-p58g-j8mj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java OpenID library","requires_auth":"low_privilege","summary":"An attacker can exploit timing discrepancies in the OpenID authentication process to potentially leak sensitive information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"jopenid","vendor":"jopenid_project"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-203","name":"Observable Discrepancy"},{"id":"CWE-208","name":"Observable Timing Discrepancy"}],"description":"A vulnerability, which was classified as problematic, was found in michaelliao jopenid. Affected is the function getAuthentication of the file JOpenId/src/org/expressme/openid/OpenIdManager.java. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.08 is able to address this issue. The name of the patch is c9baaa976b684637f0d5a50268e91846a7a719ab. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218460.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"michaelliao jopenid OpenIdManager.java getAuthentication timing discrepancy","id":"CVE-2010-10006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2010"},"n_packages":2,"n_references":4,"next":{"headline":"lierdakil click-reminder BaseAction.php db_query sql injection","id":"CVE-2010-10007"},"packages":[{"ecosystem":"Maven","fixed":["1.08"],"introduced":["0"],"last_affected":[],"package":"org.expressme:JOpenId","purl":null,"source":"GHSA-m4f8-p58g-j8mj"},{"ecosystem":"Maven","fixed":["1.08"],"introduced":["0"],"last_affected":[],"package":"org.expressme:JOpenId","purl":"pkg:maven/org.expressme/JOpenId","source":"GHSA-m4f8-p58g-j8mj"}],"prev":{"headline":"Information Cards Module cross site scripting","id":"CVE-2010-10004"},"products":["jopenid"],"published":"2023-01-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["michaelliao"]},"summary":"An attacker can exploit timing discrepancies in the OpenID authentication process to potentially leak sensitive information.","url":"https://insights.sbomify.com/CVE-2010-10006/"}