# CVE-2010-10006: michaelliao jopenid OpenIdManager.java getAuthentication timing discrepancy

> An attacker can exploit timing discrepancies in the OpenID authentication process to potentially leak sensitive information.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-m4f8-p58g-j8mj

## What is CVE-2010-10006?

CVE-2010-10006 is a low-severity vulnerability in michaelliao jopenid, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, was found in michaelliao jopenid. Affected is the function getAuthentication of the file JOpenId/src/org/expressme/openid/OpenIdManager.java. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.08 is able to address this issue. The name of the patch is c9baaa976b684637f0d5a50268e91846a7a719ab. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218460.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2010-10006?

2 open source packages ship an affected version, including org.expressme:JOpenId. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.expressme:JOpenId` | Maven | All versions | 1.08 |
| `org.expressme:JOpenId` | Maven | All versions | 1.08 |

Products: Jopenid Project Jopenid.

## How do I fix CVE-2010-10006?

Upgrade org.expressme:JOpenId to 1.08 or later.

## Is CVE-2010-10006 being exploited?

There is no known exploitation of CVE-2010-10006 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-10006 and fix it if it is affected.

What it is: CVE-2010-10006 is a low-severity vulnerability in michaelliao jopenid, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-10006 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.expressme:JOpenId (Maven): affected all versions; fixed in 1.08
- org.expressme:JOpenId (Maven): affected all versions; fixed in 1.08

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-10006/ (Markdown: https://insights.sbomify.com/CVE-2010-10006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-10006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-10006
- OSV: https://osv.dev/vulnerability/CVE-2010-10006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-10006/
Summaries are generated and may contain mistakes; the official description above is the record.
