{"answers":{"affected":"2 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-openidprovider. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-10008 in the wild and no public exploit code.","fix":"Upgrade simplesamlphp/simplesamlphp-module-openidprovider to 0.9.0 or later.","what":"CVE-2010-10008 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openidprovider, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-10008 and fix it if it is affected.\n\nWhat it is: CVE-2010-10008 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openidprovider, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-10008 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simplesamlphp/simplesamlphp-module-openidprovider (Packagist): affected all versions; fixed in 0.9.0\n- simplesamlphp/simplesamlphp-module-openidprovider (Packagist): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-10008/ (Markdown: https://insights.sbomify.com/CVE-2010-10008/index.md)","id":"CVE-2010-10008","markdown":"https://insights.sbomify.com/CVE-2010-10008/index.md","name":"CVE-2010-10008","record":{"aliases":["GHSA-chgc-rqjr-46gg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SimpleSAMLphp OpenID module","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the StateID argument in the trust template, requiring an upgrade to the OpenID provider module.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"simplesamlphp-module-openidprovider","vendor":"simplesamlphp"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file templates/trust.tpl.php. The manipulation of the argument StateID leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The identifier of the patch is 8365d48c863cf06ccf1465cc0a161cefae29d69d. It is recommended to upgrade the affected component. The identifier VDB-218473 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"simplesamlphp simplesamlphp-module-openidprovider trust.tpl.php cross site scripting","id":"CVE-2010-10008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":2,"n_references":4,"next":{"headline":"frioux ptome sql injection","id":"CVE-2010-10009"},"packages":[{"ecosystem":"Packagist","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-openidprovider","purl":null,"source":"GHSA-chgc-rqjr-46gg"},{"ecosystem":"Packagist","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"simplesamlphp/simplesamlphp-module-openidprovider","purl":"pkg:composer/simplesamlphp/simplesamlphp-module-openidprovider","source":"GHSA-chgc-rqjr-46gg"}],"prev":{"headline":"lierdakil click-reminder BaseAction.php db_query sql injection","id":"CVE-2010-10007"},"products":["simplesamlphp-module-openidprovider"],"published":"2023-01-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-25","vendors":["simplesamlphp"]},"summary":"Remote attackers can execute arbitrary scripts via the StateID argument in the trust template, requiring an upgrade to the OpenID provider module.","url":"https://insights.sbomify.com/CVE-2010-10008/"}