# CVE-2010-10008: simplesamlphp simplesamlphp-module-openidprovider trust.tpl.php cross site scripting

> Remote attackers can execute arbitrary scripts via the StateID argument in the trust template, requiring an upgrade to the OpenID provider module.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-chgc-rqjr-46gg

## What is CVE-2010-10008?

CVE-2010-10008 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openidprovider, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file templates/trust.tpl.php. The manipulation of the argument StateID leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The identifier of the patch is 8365d48c863cf06ccf1465cc0a161cefae29d69d. It is recommended to upgrade the affected component. The identifier VDB-218473 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-10008?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp-module-openidprovider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp-module-openidprovider` | Packagist | All versions | 0.9.0 |
| `simplesamlphp/simplesamlphp-module-openidprovider` | Packagist | All versions | 0.9.0 |

Products: Simplesamlphp Simplesamlphp-Module-Openidprovider.

## How do I fix CVE-2010-10008?

Upgrade simplesamlphp/simplesamlphp-module-openidprovider to 0.9.0 or later.

## Is CVE-2010-10008 being exploited?

There is no known exploitation of CVE-2010-10008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-10008 and fix it if it is affected.

What it is: CVE-2010-10008 is a low-severity cross-site scripting vulnerability in simplesamlphp-module-openidprovider, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-10008 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp-module-openidprovider (Packagist): affected all versions; fixed in 0.9.0
- simplesamlphp/simplesamlphp-module-openidprovider (Packagist): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-10008/ (Markdown: https://insights.sbomify.com/CVE-2010-10008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-10008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-10008
- OSV: https://osv.dev/vulnerability/CVE-2010-10008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-10008/
Summaries are generated and may contain mistakes; the official description above is the record.
