CVE-2010-1104 Moderate severity vulnerability that affects Zope2
Remote attackers can inject arbitrary web script or HTML via error messages in Zope, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-1104?
CVE-2010-1104 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.
Weakness: CWE-79
Which versions are affected by CVE-2010-1104?
11 open source packages ship an affected version, including zope2 and Zope2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zope2 PyPI | From 2.10.0 | 2.10.11 |
zope2 PyPI | From 2.11.0 | 2.11.6 |
zope2 PyPI | From 2.12.0 | 2.12.3 |
zope2 PyPI | From 2.8.0 | 2.8.12, 2.9.12, 2.10.11, 2.11.6, 2.12.3 |
zope2 PyPI | From 2.8.0 | 2.8.12 |
zope2 PyPI | From 2.9.0 | 2.9.12 |
5 more packages
Zope2 PyPI | From 2.10.0 | 2.10.11 |
Zope2 PyPI | From 2.11.0 | 2.11.6 |
Zope2 PyPI | From 2.12.0 | 2.12.3 |
Zope2 PyPI | From 2.8.0 | 2.8.12 |
Zope2 PyPI | From 2.9.0 | 2.9.12 |
Products include Zope Zope.
How do I fix CVE-2010-1104?
Upgrade zope2 to a fixed version for your release line: 2.10.11, 2.11.6, 2.12.3 or 2.8.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-1104 being exploited?
There is no known exploitation of CVE-2010-1104 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2000-0062 Zope DTML implementation Improper Authentication
- CVE-2021-32674 Remote Code Execution via traversal in TAL expressions
- CVE-2000-1211 Zope does not properly perform security registration for legacy names
- CVE-2002-0170 Zope does not properly verify the access for objects with proxy roles
- CVE-2002-0688 ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions
Sources
Also known as GHSA-v7q8-wvvh-c97p, PYSEC-2026-765.