# CVE-2010-1104: Moderate severity vulnerability that affects Zope2

> Remote attackers can inject arbitrary web script or HTML via error messages in Zope, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Mar 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-v7q8-wvvh-c97p, PYSEC-2026-765

## What is CVE-2010-1104?

CVE-2010-1104 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-1104?

11 open source packages ship an affected version, including zope2 and Zope2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope2` | PyPI | From 2.10.0 | 2.10.11 |
| `zope2` | PyPI | From 2.11.0 | 2.11.6 |
| `zope2` | PyPI | From 2.12.0 | 2.12.3 |
| `zope2` | PyPI | From 2.8.0 | 2.8.12, 2.9.12, 2.10.11, 2.11.6, 2.12.3 |
| `zope2` | PyPI | From 2.8.0 | 2.8.12 |
| `zope2` | PyPI | From 2.9.0 | 2.9.12 |
| `Zope2` | PyPI | From 2.10.0 | 2.10.11 |
| `Zope2` | PyPI | From 2.11.0 | 2.11.6 |
| `Zope2` | PyPI | From 2.12.0 | 2.12.3 |
| `Zope2` | PyPI | From 2.8.0 | 2.8.12 |
| `Zope2` | PyPI | From 2.9.0 | 2.9.12 |

Products: Zope Zope.

## How do I fix CVE-2010-1104?

Upgrade zope2 to a fixed version for your release line: 2.10.11, 2.11.6, 2.12.3 or 2.8.12.

## Is CVE-2010-1104 being exploited?

There is no known exploitation of CVE-2010-1104 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0170](https://insights.sbomify.com/CVE-2002-0170/): Zope does not properly verify the access for objects with proxy roles (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1104 and fix it if it is affected.

What it is: CVE-2010-1104 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-1104 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope2 (PyPI): affected from 2.10.0; fixed in 2.10.11
- zope2 (PyPI): affected from 2.11.0; fixed in 2.11.6
- zope2 (PyPI): affected from 2.12.0; fixed in 2.12.3
- zope2 (PyPI): affected from 2.8.0; fixed in 2.8.12, 2.9.12, 2.10.11, 2.11.6, 2.12.3
- zope2 (PyPI): affected from 2.8.0; fixed in 2.8.12
- zope2 (PyPI): affected from 2.9.0; fixed in 2.9.12
- Zope2 (PyPI): affected from 2.10.0; fixed in 2.10.11
- Zope2 (PyPI): affected from 2.11.0; fixed in 2.11.6
- Zope2 (PyPI): affected from 2.12.0; fixed in 2.12.3
- Zope2 (PyPI): affected from 2.8.0; fixed in 2.8.12
- Zope2 (PyPI): affected from 2.9.0; fixed in 2.9.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1104/ (Markdown: https://insights.sbomify.com/CVE-2010-1104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1104
- OSV: https://osv.dev/vulnerability/CVE-2010-1104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1104/
Summaries are generated and may contain mistakes; the official description above is the record.
