# CVE-2010-1330: Cross-site Scripting in in JRuby

> Remote attackers can execute cross-site scripting attacks in JRuby applications by exploiting a UTF-8 handling flaw in the regex engine when Unicode mode is enabled.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2012
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2010-1330, GHSA-wmq2-jc9m-xp4m

## What is CVE-2010-1330?

CVE-2010-1330 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Nov 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted string.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-1330?

2 open source packages ship an affected version, including org.jruby:jruby-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jruby:jruby-core` | Maven | All versions | 1.4.1 |
| `org.jruby:jruby-core` | Maven | All versions | 1.4.1 |

Products: Jruby Jruby.

## How do I fix CVE-2010-1330?

Upgrade org.jruby:jruby-core to 1.4.1 or later.

## Is CVE-2010-1330 being exploited?

There is no known exploitation of CVE-2010-1330 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-46551](https://insights.sbomify.com/CVE-2025-46551/): JRuby-OpenSSL has hostname verification disabled by default (medium 5.7)
- [CVE-2012-5370](https://insights.sbomify.com/CVE-2012-5370/): JRuby denial of service via Hash Collision (medium 5.0)
- [CVE-2011-4838](https://insights.sbomify.com/CVE-2011-4838/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1330 and fix it if it is affected.

What it is: CVE-2010-1330 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Nov 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-1330 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jruby:jruby-core (Maven): affected all versions; fixed in 1.4.1
- org.jruby:jruby-core (Maven): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1330/ (Markdown: https://insights.sbomify.com/CVE-2010-1330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1330
- OSV: https://osv.dev/vulnerability/CVE-2010-1330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1330/
Summaries are generated and may contain mistakes; the official description above is the record.
