# CVE-2010-1587: Apache ActiveMQ Sensitive Information Disclosure via the Jetty ResourceHandler

> Remote attackers can read JSP source code in Apache ActiveMQ admin pages by manipulating URI slashes, exposing sensitive application logic.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-v2c9-9m8v-8jjm

## What is CVE-2010-1587?

CVE-2010-1587 is a medium-severity vulnerability in Apache Activemq, published on 28 Apr 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jetty ResourceHandler in Apache ActiveMQ 5.x before 5.3.2 and 5.4.x before 5.4.0 allows remote attackers to read JSP source code via a // (slash slash) initial substring in a URI for (1) admin/index.jsp, (2) admin/queues.jsp, or (3) admin/topics.jsp.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2010-1587?

2 open source packages ship an affected version, including org.apache.activemq:activemq-web-console. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-web-console` | Maven | From 5.0.0 | 5.3.2 |
| `org.apache.activemq:activemq-web-console` | Maven | From 5.0.0 | 5.3.2 |

Products: Apache Activemq.

## How do I fix CVE-2010-1587?

Upgrade org.apache.activemq:activemq-web-console to 5.3.2 or later.

## Is CVE-2010-1587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-1587 exists.

Public exploit code:

- Apache ActiveMQ 5.2/5.3 - Source Code Information Disclosure (exploitdb)
- Apache ActiveMQ JSP Files Source Disclosure (metasploit)
- Apache ActiveMQ Directory Traversal (metasploit)

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1587 and fix it if it is affected.

What it is: CVE-2010-1587 is a medium-severity vulnerability in Apache Activemq, published on 28 Apr 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-1587 exists.

Affected packages and fixed versions:
- org.apache.activemq:activemq-web-console (Maven): affected from 5.0.0; fixed in 5.3.2
- org.apache.activemq:activemq-web-console (Maven): affected from 5.0.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1587/ (Markdown: https://insights.sbomify.com/CVE-2010-1587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1587
- OSV: https://osv.dev/vulnerability/CVE-2010-1587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1587/
Summaries are generated and may contain mistakes; the official description above is the record.
