# CVE-2010-1593: SilverStripe vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via CommenterURL and Search parameters in SilverStripe, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Apr 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-wg4m-vvp6-2hc5

## What is CVE-2010-1593?

CVE-2010-1593 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 28 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (1) the CommenterURL parameter to PostCommentForm, and in the Forum module before 0.2.5 in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (2) the Search parameter to forums/search (aka the search script).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-1593?

4 open source packages ship an affected version, including silverstripe/cms and silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/cms` | Packagist | All versions | 2.3.5 |
| `silverstripe/cms` | Packagist | All versions | 2.3.5 |
| `silverstripe/framework` | Packagist | All versions | 2.3.5 |
| `silverstripe/framework` | Packagist | All versions | 2.3.5 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2010-1593?

Upgrade silverstripe/cms to 2.3.5 or later.

## Is CVE-2010-1593 being exploited?

There is no known exploitation of CVE-2010-1593 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1593 and fix it if it is affected.

What it is: CVE-2010-1593 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 28 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-1593 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/cms (Packagist): affected all versions; fixed in 2.3.5
- silverstripe/cms (Packagist): affected all versions; fixed in 2.3.5
- silverstripe/framework (Packagist): affected all versions; fixed in 2.3.5
- silverstripe/framework (Packagist): affected all versions; fixed in 2.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1593/ (Markdown: https://insights.sbomify.com/CVE-2010-1593/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1593
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1593
- OSV: https://osv.dev/vulnerability/CVE-2010-1593

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1593/
Summaries are generated and may contain mistakes; the official description above is the record.
