CVE-2010-1614 Moodle vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML via Login-As or Global Search features, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-1614?
CVE-2010-1614 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2010-1614?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
Products include Moodle Moodle.
How do I fix CVE-2010-1614?
Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-1614 being exploited?
There is no known exploitation of CVE-2010-1614 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-5fgv-cvr8-xg48.