# CVE-2010-1614: Moodle vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via Login-As or Global Search features, potentially leading to session hijacking or data theft.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-5fgv-cvr8-xg48

## What is CVE-2010-1614?

CVE-2010-1614 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine.  NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-1614?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 1.8.0 | 1.8.12 |
| `moodle/moodle` | Packagist | From 1.8.0 | 1.8.12 |
| `moodle/moodle` | Packagist | From 1.9.0 | 1.9.8 |
| `moodle/moodle` | Packagist | From 1.9.0 | 1.9.8 |

Products: Moodle Moodle.

## How do I fix CVE-2010-1614?

Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.

## Is CVE-2010-1614 being exploited?

There is no known exploitation of CVE-2010-1614 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1614 and fix it if it is affected.

What it is: CVE-2010-1614 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-1614 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12
- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12
- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8
- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1614/ (Markdown: https://insights.sbomify.com/CVE-2010-1614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1614
- OSV: https://osv.dev/vulnerability/CVE-2010-1614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1614/
Summaries are generated and may contain mistakes; the official description above is the record.
