CVE-2010-1615 Moodle vulnerable to SQL injection

High 7.5 Published Updated

Remote attackers can execute arbitrary SQL commands in Moodle via wiki and form vulnerabilities, potentially accessing or modifying database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2010-1615?

CVE-2010-1615 is a high-severity SQL injection vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Multiple SQL injection vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to execute arbitrary SQL commands via vectors related to (1) the add_to_log function in mod/wiki/view.php in the wiki module, or (2) "data validation in some forms elements" related to lib/form/selectgroups.php.

Weakness: CWE-89

Which versions are affected by CVE-2010-1615?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 1.8.01.8.12
moodle/moodle PackagistFrom 1.8.01.8.12
moodle/moodle PackagistFrom 1.9.01.9.8
moodle/moodle PackagistFrom 1.9.01.9.8

Products include Moodle Moodle.

How do I fix CVE-2010-1615?

Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2010-1615 being exploited?

There is no known exploitation of CVE-2010-1615 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-9xp2-5fr9-7mwm.

Is CVE-2010-1615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free