CVE-2010-1616 Moodle is vulnerable to unauthorized new accounts creation
Teachers can bypass capability restrictions to create new user accounts during course restoration, leading to unauthorized privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-1616?
CVE-2010-1616 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.
Which versions are affected by CVE-2010-1616?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
Products include Moodle Moodle.
How do I fix CVE-2010-1616?
Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2010-1616 being exploited?
There is no known exploitation of CVE-2010-1616 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-966m-m549-2878.