{"answers":{"affected":"4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-1616 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.","what":"CVE-2010-1616 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-1616 and fix it if it is affected.\n\nWhat it is: CVE-2010-1616 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 29 Apr 2010. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-1616 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12\n- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12\n- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8\n- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-1616/ (Markdown: https://insights.sbomify.com/CVE-2010-1616/index.md)","id":"CVE-2010-1616","markdown":"https://insights.sbomify.com/CVE-2010-1616/index.md","name":"CVE-2010-1616","record":{"aliases":["GHSA-966m-m549-2878"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Teachers can bypass capability restrictions to create new user accounts during course restoration, leading to unauthorized privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle is vulnerable to unauthorized new accounts creation","id":"CVE-2010-1616","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2010"},"n_packages":4,"n_references":4,"next":{"headline":"Moodle doesn't properly check role","id":"CVE-2010-1617"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.12"],"introduced":["1.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-966m-m549-2878"},{"ecosystem":"Packagist","fixed":["1.8.12"],"introduced":["1.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-966m-m549-2878"},{"ecosystem":"Packagist","fixed":["1.9.8"],"introduced":["1.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-966m-m549-2878"},{"ecosystem":"Packagist","fixed":["1.9.8"],"introduced":["1.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-966m-m549-2878"}],"prev":{"headline":"Moodle vulnerable to SQL injection","id":"CVE-2010-1615"},"products":["n/a"],"published":"2010-04-29","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Teachers can bypass capability restrictions to create new user accounts during course restoration, leading to unauthorized privilege escalation.","url":"https://insights.sbomify.com/CVE-2010-1616/"}