CVE-2010-1618 phpCAS client library and Moodle Cross-site Scripting vulnerability
Remote attackers can inject arbitrary web script or HTML via crafted URLs in the phpCAS client library, affecting Moodle installations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-1618?
CVE-2010-1618 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.
Weakness: CWE-79
Which versions are affected by CVE-2010-1618?
6 open source packages ship an affected version, including moodle/moodle and apereo/phpcas. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.8.0 | 1.8.12 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
moodle/moodle Packagist | From 1.9.0 | 1.9.8 |
apereo/phpcas Packagist | All versions | 1.1.0 |
apereo/phpcas Packagist | All versions | 1.1.0 |
Products include Ja-Sig Phpcas Client Library, Moodle Moodle.
How do I fix CVE-2010-1618?
Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-1618 being exploited?
There is no known exploitation of CVE-2010-1618 in the wild and no public exploit code.
Sources
Also known as GHSA-45ch-hxgr-vx8j.