{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle and apereo/phpcas. It affects 2 products.","exploited":"There is no known exploitation of CVE-2010-1618 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.","what":"CVE-2010-1618 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-1618 and fix it if it is affected.\n\nWhat it is: CVE-2010-1618 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-1618 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12\n- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12\n- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8\n- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8\n- apereo/phpcas (Packagist): affected all versions; fixed in 1.1.0\n- apereo/phpcas (Packagist): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-1618/ (Markdown: https://insights.sbomify.com/CVE-2010-1618/index.md)","id":"CVE-2010-1618","markdown":"https://insights.sbomify.com/CVE-2010-1618/index.md","name":"CVE-2010-1618","record":{"aliases":["GHSA-45ch-hxgr-vx8j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpCAS client library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted URLs in the phpCAS client library, affecting Moodle installations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpcas_client_library","vendor":"ja-sig"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpCAS client library and Moodle Cross-site Scripting vulnerability","id":"CVE-2010-1618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2010"},"n_packages":6,"n_references":5,"next":{"headline":"Moodle vulnerable to Cross-site Scripting","id":"CVE-2010-1619"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"apereo/phpcas","purl":null,"source":"GHSA-45ch-hxgr-vx8j"},{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"apereo/phpcas","purl":"pkg:composer/apereo/phpcas","source":"GHSA-45ch-hxgr-vx8j"},{"ecosystem":"Packagist","fixed":["1.8.12"],"introduced":["1.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-45ch-hxgr-vx8j"},{"ecosystem":"Packagist","fixed":["1.8.12"],"introduced":["1.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-45ch-hxgr-vx8j"},{"ecosystem":"Packagist","fixed":["1.9.8"],"introduced":["1.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-45ch-hxgr-vx8j"},{"ecosystem":"Packagist","fixed":["1.9.8"],"introduced":["1.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-45ch-hxgr-vx8j"}],"prev":{"headline":"Moodle doesn't properly check role","id":"CVE-2010-1617"},"products":["n/a"],"published":"2010-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted URLs in the phpCAS client library, affecting Moodle installations.","url":"https://insights.sbomify.com/CVE-2010-1618/"}