# CVE-2010-1618: phpCAS client library and Moodle Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via crafted URLs in the phpCAS client library, affecting Moodle installations.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-45ch-hxgr-vx8j

## What is CVE-2010-1618?

CVE-2010-1618 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-1618?

6 open source packages ship an affected version, including moodle/moodle and apereo/phpcas. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 1.8.0 | 1.8.12 |
| `moodle/moodle` | Packagist | From 1.8.0 | 1.8.12 |
| `moodle/moodle` | Packagist | From 1.9.0 | 1.9.8 |
| `moodle/moodle` | Packagist | From 1.9.0 | 1.9.8 |
| `apereo/phpcas` | Packagist | All versions | 1.1.0 |
| `apereo/phpcas` | Packagist | All versions | 1.1.0 |

Products: Ja-Sig Phpcas Client Library, Moodle Moodle.

## How do I fix CVE-2010-1618?

Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.

## Is CVE-2010-1618 being exploited?

There is no known exploitation of CVE-2010-1618 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1618 and fix it if it is affected.

What it is: CVE-2010-1618 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-1618 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12
- moodle/moodle (Packagist): affected from 1.8.0; fixed in 1.8.12
- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8
- moodle/moodle (Packagist): affected from 1.9.0; fixed in 1.9.8
- apereo/phpcas (Packagist): affected all versions; fixed in 1.1.0
- apereo/phpcas (Packagist): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1618/ (Markdown: https://insights.sbomify.com/CVE-2010-1618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1618
- OSV: https://osv.dev/vulnerability/CVE-2010-1618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1618/
Summaries are generated and may contain mistakes; the official description above is the record.
