CVE-2010-1619 Moodle vulnerable to Cross-site Scripting

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via crafted HTML entities in Moodle, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2010-1619?

CVE-2010-1619 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 29 Apr 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the fix_non_standard_entities function in the KSES HTML text cleaning library (weblib.php), as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via crafted HTML entities.

Weakness: CWE-79

Which versions are affected by CVE-2010-1619?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 1.8.01.8.12
moodle/moodle PackagistFrom 1.8.01.8.12
moodle/moodle PackagistFrom 1.9.01.9.8
moodle/moodle PackagistFrom 1.9.01.9.8

Products include Moodle Moodle.

How do I fix CVE-2010-1619?

Upgrade moodle/moodle to a fixed version for your release line: 1.8.12 or 1.9.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2010-1619 being exploited?

There is no known exploitation of CVE-2010-1619 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-hhxf-w8hj-43w6.

Is CVE-2010-1619 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free