{"answers":{"affected":"2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-1630 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.0.5 or later.","what":"CVE-2010-1630 is a high-severity vulnerability in n/a, published on 19 May 2010. It can be exploited over the network."},"fix_prompt":"Check this codebase for CVE-2010-1630 and fix it if it is affected.\n\nWhat it is: CVE-2010-1630 is a high-severity vulnerability in n/a, published on 19 May 2010. It can be exploited over the network.\nExploitation: There is no known exploitation of CVE-2010-1630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.5\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-1630/ (Markdown: https://insights.sbomify.com/CVE-2010-1630/index.md)","id":"CVE-2010-1630","markdown":"https://insights.sbomify.com/CVE-2010-1630/index.md","name":"CVE-2010-1630","record":{"aliases":["GHSA-5cvh-xqhr-5g87"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"unknown","summary":"Unspecified vulnerability in phpBB posting.php related to global announcements allows attackers to exploit forum ID handling.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Unspecified vulnerability in posting.php in phpBB before 3.0.5 has unknown impact and attack vectors related to the use of a \"forum id\" in circumstances related to a \"global announcement.\"","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB vulnerability related to use of \"forum id\" in circumstances related to a \"global announcement.\"","id":"CVE-2010-1630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2010"},"n_packages":2,"n_references":5,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2010-1631"},"packages":[{"ecosystem":"Packagist","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-5cvh-xqhr-5g87"},{"ecosystem":"Packagist","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-5cvh-xqhr-5g87"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2010-1629"},"products":["n/a"],"published":"2010-05-19","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-3224","kev_date_added":null,"published":"2008-07-18"},{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to \"two minor security-related bu","id":"CVE-2008-1766","kev_date_added":null,"published":"2008-04-12"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2025-70810","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2001-1471","kev_date_added":null,"published":"2005-04-21"},{"cvss_score":8.1,"headline":"phpBB has Password Reset Link Poisoning via Host Header injection","id":"CVE-2026-29199","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"phpBB arbitrary CSS injection","id":"CVE-2019-16108","kev_date_added":null,"published":"2020-03-19"},{"cvss_score":7.5,"headline":"phpBB Denial of Service","id":"CVE-2019-9826","kev_date_added":null,"published":"2019-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Unspecified vulnerability in phpBB posting.php related to global announcements allows attackers to exploit forum ID handling.","url":"https://insights.sbomify.com/CVE-2010-1630/"}