# CVE-2010-1630: phpBB vulnerability related to use of "forum id" in circumstances related to a "global announcement."

> Unspecified vulnerability in phpBB posting.php related to global announcements allows attackers to exploit forum ID handling.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 19 May 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5cvh-xqhr-5g87

## What is CVE-2010-1630?

CVE-2010-1630 is a high-severity vulnerability in n/a, published on 19 May 2010. It can be exploited over the network.

### Official description

Unspecified vulnerability in posting.php in phpBB before 3.0.5 has unknown impact and attack vectors related to the use of a "forum id" in circumstances related to a "global announcement."

## Which versions are affected by CVE-2010-1630?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.0.5 |
| `phpbb/phpbb` | Packagist | All versions | 3.0.5 |

Products: Phpbb Phpbb.

## How do I fix CVE-2010-1630?

Upgrade phpbb/phpbb to 3.0.5 or later.

## Is CVE-2010-1630 being exploited?

There is no known exploitation of CVE-2010-1630 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1630 and fix it if it is affected.

What it is: CVE-2010-1630 is a high-severity vulnerability in n/a, published on 19 May 2010. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2010-1630 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.5
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1630/ (Markdown: https://insights.sbomify.com/CVE-2010-1630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1630
- OSV: https://osv.dev/vulnerability/CVE-2010-1630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1630/
Summaries are generated and may contain mistakes; the official description above is the record.
