{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.axis2.wso2:axis2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-1632 in the wild and no public exploit code.","fix":"Upgrade org.apache.axis2.wso2:axis2 to 1.5.2 or later.","what":"CVE-2010-1632 is a high-severity vulnerability in n/a, published on 22 Jun 2010. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-1632 and fix it if it is affected.\n\nWhat it is: CVE-2010-1632 is a high-severity vulnerability in n/a, published on 22 Jun 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-1632 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.axis2.wso2:axis2 (Maven): affected all versions; fixed in 1.5.2\n- org.apache.axis2.wso2:axis2 (Maven): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-1632/ (Markdown: https://insights.sbomify.com/CVE-2010-1632/index.md)","id":"CVE-2010-1632","markdown":"https://insights.sbomify.com/CVE-2010-1632/index.md","name":"CVE-2010-1632","record":{"aliases":["GHSA-23vv-v25h-qwqw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Axis2","requires_auth":"none","summary":"Remote attackers can exploit improper DTD rejection in Apache Axis2 to read arbitrary files, access intranet servers, or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"axis2","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache Axis2 before 1.5.2, as used in IBM WebSphere Application Server (WAS) 7.0 through 7.0.0.12, IBM Feature Pack for Web Services 6.1.0.9 through 6.1.0.32, IBM Feature Pack for Web 2.0 1.0.1.0, Apache Synapse, Apache ODE, Apache Tuscany, Apache Geronimo, and other products, does not properly reject DTDs in SOAP messages, which allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via a crafted DTD, as demonstrated by an entity declaration in a request to the Synapse SimpleStockQuoteService.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in Apache Axis2","id":"CVE-2010-1632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2010"},"n_packages":2,"n_references":19,"next":{"headline":"Information disclosure in n/a","id":"CVE-2010-1633"},"packages":[{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.axis2.wso2:axis2","purl":null,"source":"GHSA-23vv-v25h-qwqw"},{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.axis2.wso2:axis2","purl":"pkg:maven/org.apache.axis2.wso2/axis2","source":"GHSA-23vv-v25h-qwqw"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2010-1631"},"products":["n/a"],"published":"2010-06-22","related":[{"cvss_score":10,"headline":"Hardcoded credentials in n/a","id":"CVE-2010-0219","kev_date_added":null,"published":"2010-10-18"},{"cvss_score":6.4,"headline":"Improper Authentication in Apache Axis2","id":"CVE-2012-5351","kev_date_added":null,"published":"2012-10-09"},{"cvss_score":5.8,"headline":"Apache Axis2 has Improper Input Validation","id":"CVE-2012-5785","kev_date_added":null,"published":"2012-11-04"},{"cvss_score":5.8,"headline":"Apache Axis2 Vulnerable to XML Signature wrapping attack","id":"CVE-2012-4418","kev_date_added":null,"published":"2012-10-09"},{"cvss_score":4.3,"headline":"Improper Neutralization of Input During Web Page Generation in Apache Axis2","id":"CVE-2010-2103","kev_date_added":null,"published":"2010-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can exploit improper DTD rejection in Apache Axis2 to read arbitrary files, access intranet servers, or cause denial of service.","url":"https://insights.sbomify.com/CVE-2010-1632/"}