# CVE-2010-1632: Improper Input Validation in Apache Axis2

> Remote attackers can exploit improper DTD rejection in Apache Axis2 to read arbitrary files, access intranet servers, or cause denial of service.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-23vv-v25h-qwqw

## What is CVE-2010-1632?

CVE-2010-1632 is a high-severity vulnerability in n/a, published on 22 Jun 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Axis2 before 1.5.2, as used in IBM WebSphere Application Server (WAS) 7.0 through 7.0.0.12, IBM Feature Pack for Web Services 6.1.0.9 through 6.1.0.32, IBM Feature Pack for Web 2.0 1.0.1.0, Apache Synapse, Apache ODE, Apache Tuscany, Apache Geronimo, and other products, does not properly reject DTDs in SOAP messages, which allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via a crafted DTD, as demonstrated by an entity declaration in a request to the Synapse SimpleStockQuoteService.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2010-1632?

2 open source packages ship an affected version, including org.apache.axis2.wso2:axis2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.axis2.wso2:axis2` | Maven | All versions | 1.5.2 |
| `org.apache.axis2.wso2:axis2` | Maven | All versions | 1.5.2 |

Products: Apache Axis2.

## How do I fix CVE-2010-1632?

Upgrade org.apache.axis2.wso2:axis2 to 1.5.2 or later.

## Is CVE-2010-1632 being exploited?

There is no known exploitation of CVE-2010-1632 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2010-0219](https://insights.sbomify.com/CVE-2010-0219/): Hardcoded credentials in n/a (critical 10.0)
- [CVE-2012-5351](https://insights.sbomify.com/CVE-2012-5351/): Improper Authentication in Apache Axis2 (medium 6.4)
- [CVE-2012-5785](https://insights.sbomify.com/CVE-2012-5785/): Apache Axis2 has Improper Input Validation (medium 5.8)
- [CVE-2012-4418](https://insights.sbomify.com/CVE-2012-4418/): Apache Axis2 Vulnerable to XML Signature wrapping attack (medium 5.8)
- [CVE-2010-2103](https://insights.sbomify.com/CVE-2010-2103/): Improper Neutralization of Input During Web Page Generation in Apache Axis2 (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1632 and fix it if it is affected.

What it is: CVE-2010-1632 is a high-severity vulnerability in n/a, published on 22 Jun 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-1632 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.axis2.wso2:axis2 (Maven): affected all versions; fixed in 1.5.2
- org.apache.axis2.wso2:axis2 (Maven): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1632/ (Markdown: https://insights.sbomify.com/CVE-2010-1632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1632
- OSV: https://osv.dev/vulnerability/CVE-2010-1632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1632/
Summaries are generated and may contain mistakes; the official description above is the record.
