# CVE-2010-1870: Server side object manipulation in Apache Struts

> Remote attackers can execute arbitrary code by exploiting OGNL expression evaluation flaws in the Struts 2 framework.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-x5fc-pgpx-59j5

## What is CVE-2010-1870?

CVE-2010-1870 is a medium-severity code injection vulnerability in Apache Struts, published on 17 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OGNL extensive expression evaluation capability in XWork in Struts 2.0.0 through 2.1.8.1, as used in Atlassian Fisheye, Crucible, and possibly other products, uses a permissive whitelist, which allows remote attackers to modify server-side context objects and bypass the "#" protection mechanism in ParameterInterceptors via the (1) #context, (2) #_memberAccess, (3) #root, (4) #this, (5) #_typeResolver, (6) #_classResolver, (7) #_traceEvaluations, (8) #_lastEvaluation, (9) #_keepLastEvaluation, and possibly other OGNL context variables, a different vulnerability than CVE-2008-6504.

## Which versions are affected by CVE-2010-1870?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.1 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.2.1 |

Products: Apache Struts.

## How do I fix CVE-2010-1870?

Upgrade org.apache.struts:struts2-core to 2.2.1 or later.

## Is CVE-2010-1870 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-1870 exists.

Public exploit code:

- Apache Struts Remote Command Execution (metasploit)
- Struts2/XWork < 2.2.0 - Remote Command Execution (exploitdb)
- Apache Struts < 2.2.0 - Remote Command Execution (Metasploit) (exploitdb)
- ListSERV Maestro <= 9.0-8 RCE (nuclei): http/cves/2010/CVE-2010-1870.yaml

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-1870 and fix it if it is affected.

What it is: CVE-2010-1870 is a medium-severity code injection vulnerability in Apache Struts, published on 17 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-1870 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.1
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-1870/ (Markdown: https://insights.sbomify.com/CVE-2010-1870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-1870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-1870
- OSV: https://osv.dev/vulnerability/CVE-2010-1870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-1870/
Summaries are generated and may contain mistakes; the official description above is the record.
