CVE-2010-20121 EasyFTP Server <= 1.7.0.11 CWD Command Stack Buffer Overflow

Critical 9.3 Published Updated

Remote attackers can execute arbitrary code via a stack buffer overflow in the CWD command, affecting EasyFTP Server installations with default anonymous access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2010-20121?

CVE-2010-20121 is a critical memory corruption vulnerability in KMiNT21 Software EasyFTP Server, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

EasyFTP Server versions up to 1.7.0.11 contain a stack-based buffer overflow vulnerability in the FTP command parser. When processing the CWD (Change Working Directory) command, the server fails to properly validate the length of the input string, allowing attackers to overwrite memory on the stack. This flaw enables remote code execution without authentication, as EasyFTP allows anonymous access by default. The vulnerability was resolved in version 1.7.0.12, after which the product was renamed “UplusFtp.”

Weakness: CWE-121

Which versions are affected by CVE-2010-20121?

It affects 1 product.

Products include Easyftp Server Project Easyftp Server.

How do I fix CVE-2010-20121?

No fix has been published for CVE-2010-20121 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2010-20121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-20121 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-p9m6-qf43-qh47.

Is CVE-2010-20121 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free