# CVE-2010-20121: EasyFTP Server <= 1.7.0.11 CWD Command Stack Buffer Overflow

> Remote attackers can execute arbitrary code via a stack buffer overflow in the CWD command, affecting EasyFTP Server installations with default anonymous access.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Aug 2025
- **Updated:** 15 May 2026
- **Also known as:** GHSA-p9m6-qf43-qh47

## What is CVE-2010-20121?

CVE-2010-20121 is a critical memory corruption vulnerability in KMiNT21 Software EasyFTP Server, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

EasyFTP Server versions up to 1.7.0.11 contain a stack-based buffer overflow vulnerability in the FTP command parser. When processing the CWD (Change Working Directory) command, the server fails to properly validate the length of the input string, allowing attackers to overwrite memory on the stack. This flaw enables remote code execution without authentication, as EasyFTP allows anonymous access by default. The vulnerability was resolved in version 1.7.0.12, after which the product was renamed “UplusFtp.”

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2010-20121?

It affects 1 product.


Products: Easyftp Server Project Easyftp Server.

## How do I fix CVE-2010-20121?

No fix has been published for CVE-2010-20121 yet. Limit exposure of the affected software until one is available.

## Is CVE-2010-20121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-20121 exists.

Public exploit code:

- EasyFTP Server CWD Command Stack Buffer Overflow (metasploit)

## Other vulnerabilities in KMiNT21 Software EasyFTP Server

- [CVE-2010-20113](https://insights.sbomify.com/CVE-2010-20113/): EasyFTP Server list.html path Stack Buffer Overflow (critical 9.3)
- [CVE-2011-10005](https://insights.sbomify.com/CVE-2011-10005/): EasyFTP MKD Command buffer overflow (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-20121 and fix it if it is affected.

What it is: CVE-2010-20121 is a critical memory corruption vulnerability in KMiNT21 Software EasyFTP Server, published on 21 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-20121 exists.

Affected product: KMiNT21 Software EasyFTP Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-20121/ (Markdown: https://insights.sbomify.com/CVE-2010-20121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-20121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-20121
- OSV: https://osv.dev/vulnerability/CVE-2010-20121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-20121/
Summaries are generated and may contain mistakes; the official description above is the record.
