CVE-2010-2057 Improper Authentication in Apache MyFaces
Remote attackers can modify encrypted View State via padding oracle attacks due to missing MAC, compromising data integrity in Apache MyFaces applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-2057?
CVE-2010-2057 is a medium-severity vulnerability in n/a, published on 20 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
shared/util/StateUtils.java in Apache MyFaces 1.1.x before 1.1.8, 1.2.x before 1.2.9, and 2.0.x before 2.0.1 uses an encrypted View State without a Message Authentication Code (MAC), which makes it easier for remote attackers to perform successful modifications of the View State via a padding oracle attack.
Weakness: CWE-310
Which versions are affected by CVE-2010-2057?
12 open source packages ship an affected version, including org.apache.myfaces.core:myfaces-impl and org.apache.myfaces.shared:myfaces-shared-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.myfaces.core:myfaces-impl Maven | From 1.1.0 | 1.1.8 |
org.apache.myfaces.core:myfaces-impl Maven | From 1.1.0 | 1.1.8 |
org.apache.myfaces.core:myfaces-impl Maven | From 1.2.0 | 1.2.9 |
org.apache.myfaces.core:myfaces-impl Maven | From 1.2.0 | 1.2.9 |
org.apache.myfaces.core:myfaces-impl Maven | From 2.0.0 | 2.0.1 |
org.apache.myfaces.core:myfaces-impl Maven | From 2.0.0 | 2.0.1 |
6 more packages
org.apache.myfaces.shared:myfaces-shared-core Maven | From 1.1.0 | 1.1.8 |
org.apache.myfaces.shared:myfaces-shared-core Maven | From 1.1.0 | 1.1.8 |
org.apache.myfaces.shared:myfaces-shared-core Maven | From 1.2.0 | 1.2.9 |
org.apache.myfaces.shared:myfaces-shared-core Maven | From 1.2.0 | 1.2.9 |
org.apache.myfaces.shared:myfaces-shared-core Maven | From 2.0.0 | 2.0.1 |
org.apache.myfaces.shared:myfaces-shared-core Maven | From 2.0.0 | 2.0.1 |
Products include Apache Myfaces.
How do I fix CVE-2010-2057?
Upgrade org.apache.myfaces.core:myfaces-impl to a fixed version for your release line: 1.1.8, 1.2.9 or 2.0.1.
Is CVE-2010-2057 being exploited?
There is no known exploitation of CVE-2010-2057 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4fv4-cq5v-x45m.