# CVE-2010-2076: Improper Input Validation in Apache CXF

> Remote attackers can read arbitrary files, access intranet servers, or cause denial of service via crafted DTDs in SOAP messages.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-v8q2-94f6-6xq2

## What is CVE-2010-2076?

CVE-2010-2076 is a critical vulnerability in Apache Cxf, published on 19 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache CXF 2.0.x before 2.0.13, 2.1.x before 2.1.10, and 2.2.x before 2.2.9, as used in Apache ServiceMix, Apache Camel, Apache Chemistry, Apache jUDDI, Apache Geronimo, and other products, does not properly reject DTDs in SOAP messages, which allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via a crafted DTD, as demonstrated by an entity declaration in a request to samples/wsdl_first_pure_xml, a similar issue to CVE-2010-1632.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2010-2076?

6 open source packages ship an affected version, including org.apache.cxf:cxf-rt-frontend-jaxrs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.0.0 | 2.0.13 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.0.0 | 2.0.13 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.1.0 | 2.1.10 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.1.0 | 2.1.10 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.2.0 | 2.2.9 |
| `org.apache.cxf:cxf-rt-frontend-jaxrs` | Maven | From 2.2.0 | 2.2.9 |

Products: Apache Cxf.

## How do I fix CVE-2010-2076?

Upgrade org.apache.cxf:cxf-rt-frontend-jaxrs to a fixed version for your release line: 2.0.13, 2.1.10 or 2.2.9.

## Is CVE-2010-2076 being exploited?

There is no known exploitation of CVE-2010-2076 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2076 and fix it if it is affected.

What it is: CVE-2010-2076 is a critical vulnerability in Apache Cxf, published on 19 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-2076 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.0.0; fixed in 2.0.13
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.0.0; fixed in 2.0.13
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.1.0; fixed in 2.1.10
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.1.0; fixed in 2.1.10
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.2.0; fixed in 2.2.9
- org.apache.cxf:cxf-rt-frontend-jaxrs (Maven): affected from 2.2.0; fixed in 2.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2076/ (Markdown: https://insights.sbomify.com/CVE-2010-2076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2076
- OSV: https://osv.dev/vulnerability/CVE-2010-2076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2076/
Summaries are generated and may contain mistakes; the official description above is the record.
