{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.axis2.wso2:axis2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2103 in the wild and no public exploit code.","fix":"Upgrade org.apache.axis2.wso2:axis2 to 1.6.0 or later.","what":"CVE-2010-2103 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 May 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2103 and fix it if it is affected.\n\nWhat it is: CVE-2010-2103 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 May 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2103 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.axis2.wso2:axis2 (Maven): affected from 1.4.1; fixed in 1.6.0\n- org.apache.axis2.wso2:axis2 (Maven): affected from 1.4.1; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2103/ (Markdown: https://insights.sbomify.com/CVE-2010-2103/index.md)","id":"CVE-2010-2103","markdown":"https://insights.sbomify.com/CVE-2010-2103/index.md","name":"CVE-2010-2103","record":{"aliases":["GHSA-23x8-j7hm-5xwf"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Axis2 admin console","requires_auth":"high_privilege","summary":"Remote attackers can inject arbitrary web script into the Apache Axis2 administration console via the modules parameter, potentially compromising admin sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"axis2","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in axis2-admin/axis2-admin/engagingglobally in the administration console in Apache Axis2/Java 1.4.1, 1.5.1, and possibly other versions, as used in SAP Business Objects 12, 3com IMC, and possibly other products, allows remote attackers to inject arbitrary web script or HTML via the modules parameter.  NOTE: some of these details are obtained from third party information.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2010-05-21","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2010-05-21","kind":"exploitdb","ref":"12689","stars":null,"title":"Apache Axis2 Administration Console - (Authenticated) Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in Apache Axis2","id":"CVE-2010-2103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":2,"n_references":10,"next":{"headline":"Path traversal in n/a","id":"CVE-2010-2104"},"packages":[{"ecosystem":"Maven","fixed":["1.6.0"],"introduced":["1.4.1"],"last_affected":[],"package":"org.apache.axis2.wso2:axis2","purl":null,"source":"GHSA-23x8-j7hm-5xwf"},{"ecosystem":"Maven","fixed":["1.6.0"],"introduced":["1.4.1"],"last_affected":[],"package":"org.apache.axis2.wso2:axis2","purl":"pkg:maven/org.apache.axis2.wso2/axis2","source":"GHSA-23x8-j7hm-5xwf"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2010-2102"},"products":["n/a"],"published":"2010-05-27","related":[{"cvss_score":10,"headline":"Hardcoded credentials in n/a","id":"CVE-2010-0219","kev_date_added":null,"published":"2010-10-18"},{"cvss_score":7.5,"headline":"Improper Input Validation in Apache Axis2","id":"CVE-2010-1632","kev_date_added":null,"published":"2010-06-22"},{"cvss_score":6.4,"headline":"Improper Authentication in Apache Axis2","id":"CVE-2012-5351","kev_date_added":null,"published":"2012-10-09"},{"cvss_score":5.8,"headline":"Apache Axis2 has Improper Input Validation","id":"CVE-2012-5785","kev_date_added":null,"published":"2012-11-04"},{"cvss_score":5.8,"headline":"Apache Axis2 Vulnerable to XML Signature wrapping attack","id":"CVE-2012-4418","kev_date_added":null,"published":"2012-10-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script into the Apache Axis2 administration console via the modules parameter, potentially compromising admin sessions.","url":"https://insights.sbomify.com/CVE-2010-2103/"}