# CVE-2010-2103: Improper Neutralization of Input During Web Page Generation in Apache Axis2

> Remote attackers can inject arbitrary web script into the Apache Axis2 administration console via the modules parameter, potentially compromising admin sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-23x8-j7hm-5xwf

## What is CVE-2010-2103?

CVE-2010-2103 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 May 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in axis2-admin/axis2-admin/engagingglobally in the administration console in Apache Axis2/Java 1.4.1, 1.5.1, and possibly other versions, as used in SAP Business Objects 12, 3com IMC, and possibly other products, allows remote attackers to inject arbitrary web script or HTML via the modules parameter.  NOTE: some of these details are obtained from third party information.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-2103?

2 open source packages ship an affected version, including org.apache.axis2.wso2:axis2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.axis2.wso2:axis2` | Maven | From 1.4.1 | 1.6.0 |
| `org.apache.axis2.wso2:axis2` | Maven | From 1.4.1 | 1.6.0 |

Products: Apache Axis2.

## How do I fix CVE-2010-2103?

Upgrade org.apache.axis2.wso2:axis2 to 1.6.0 or later.

## Is CVE-2010-2103 being exploited?

There is no known exploitation of CVE-2010-2103 in the wild and no public exploit code.

Public exploit code:

- Apache Axis2 Administration Console - (Authenticated) Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2010-0219](https://insights.sbomify.com/CVE-2010-0219/): Hardcoded credentials in n/a (critical 10.0)
- [CVE-2010-1632](https://insights.sbomify.com/CVE-2010-1632/): Improper Input Validation in Apache Axis2 (high 7.5)
- [CVE-2012-5351](https://insights.sbomify.com/CVE-2012-5351/): Improper Authentication in Apache Axis2 (medium 6.4)
- [CVE-2012-5785](https://insights.sbomify.com/CVE-2012-5785/): Apache Axis2 has Improper Input Validation (medium 5.8)
- [CVE-2012-4418](https://insights.sbomify.com/CVE-2012-4418/): Apache Axis2 Vulnerable to XML Signature wrapping attack (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2103 and fix it if it is affected.

What it is: CVE-2010-2103 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 May 2010. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-2103 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.axis2.wso2:axis2 (Maven): affected from 1.4.1; fixed in 1.6.0
- org.apache.axis2.wso2:axis2 (Maven): affected from 1.4.1; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2103/ (Markdown: https://insights.sbomify.com/CVE-2010-2103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2103
- OSV: https://osv.dev/vulnerability/CVE-2010-2103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2103/
Summaries are generated and may contain mistakes; the official description above is the record.
