CVE-2010-2230 Moodle Cross-site Scripting vulnerability in the KSES text cleaning filter
Authenticated users can execute cross-site scripting attacks via vbscript URIs in Moodle's text filter, potentially compromising other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-2230?
CVE-2010-2230 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 28 Jun 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The KSES text cleaning filter in lib/weblib.php in Moodle before 1.8.13 and 1.9.x before 1.9.9 does not properly handle vbscript URIs, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via HTML input.
Weakness: CWE-79
Which versions are affected by CVE-2010-2230?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 1.8.13 |
moodle/moodle Packagist | All versions | 1.8.13 |
moodle/moodle Packagist | From 1.9.0 | 1.9.9 |
moodle/moodle Packagist | From 1.9.0 | 1.9.9 |
Products include Moodle Moodle.
How do I fix CVE-2010-2230?
Upgrade moodle/moodle to a fixed version for your release line: 1.8.13 or 1.9.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-2230 being exploited?
There is no known exploitation of CVE-2010-2230 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as DEBIAN-CVE-2010-2230, GHSA-3gm8-32vv-q8mp.