{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2232 in the wild and no public exploit code.","fix":"Upgrade org.apache.derby:derby to 10.4.2.0 or later.","what":"CVE-2010-2232 is a high-severity path traversal vulnerability in Apache Derby, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-2232 and fix it if it is affected.\n\nWhat it is: CVE-2010-2232 is a high-severity path traversal vulnerability in Apache Derby, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-2232 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.derby:derby (Maven): affected from 10.1.2.1; fixed in 10.4.2.0\n- org.apache.derby:derby (Maven): affected from 10.1.2.1; fixed in 10.4.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2232/ (Markdown: https://insights.sbomify.com/CVE-2010-2232/index.md)","id":"CVE-2010-2232","markdown":"https://insights.sbomify.com/CVE-2010-2232/index.md","name":"CVE-2010-2232","record":{"aliases":["GHSA-xprw-xvvm-vqmv"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Derby database","requires_auth":"none","summary":"An attacker can overwrite existing files via export processing in Apache Derby, potentially compromising data integrity.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"derby","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Access Control in Apache Derby","id":"CVE-2010-2232","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2010"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2010-2233"},"packages":[{"ecosystem":"Maven","fixed":["10.4.2.0"],"introduced":["10.1.2.1"],"last_affected":[],"package":"org.apache.derby:derby","purl":null,"source":"GHSA-xprw-xvvm-vqmv"},{"ecosystem":"Maven","fixed":["10.4.2.0"],"introduced":["10.1.2.1"],"last_affected":[],"package":"org.apache.derby:derby","purl":"pkg:maven/org.apache.derby/derby","source":"GHSA-xprw-xvvm-vqmv"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2010-2231"},"products":["Apache Derby"],"published":"2017-10-23","related":[{"cvss_score":9.8,"headline":"Apache Derby: LDAP injection vulnerability in authenticator","id":"CVE-2022-46337","kev_date_added":null,"published":"2023-11-20"},{"cvss_score":9.1,"headline":"Improper Restriction of XML External Entity Reference in Apace Derby","id":"CVE-2015-1832","kev_date_added":null,"published":"2016-10-03"},{"cvss_score":5.3,"headline":"Improper Access Control in Apache Derby","id":"CVE-2018-1313","kev_date_added":null,"published":"2018-05-07"},{"cvss_score":5,"headline":"Apache Derby exposes user and password attributes","id":"CVE-2005-4849","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Missing authorization in n/a","id":"CVE-2006-7216","kev_date_added":null,"published":"2007-07-05"},{"cvss_score":4,"headline":"Apache Derby SQL Injection","id":"CVE-2006-7217","kev_date_added":null,"published":"2007-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["Apache Software Foundation"]},"summary":"An attacker can overwrite existing files via export processing in Apache Derby, potentially compromising data integrity.","url":"https://insights.sbomify.com/CVE-2010-2232/"}