# CVE-2010-2232: Improper Access Control in Apache Derby

> An attacker can overwrite existing files via export processing in Apache Derby, potentially compromising data integrity.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2017
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-xprw-xvvm-vqmv

## What is CVE-2010-2232?

CVE-2010-2232 is a high-severity path traversal vulnerability in Apache Derby, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2010-2232?

2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | From 10.1.2.1 | 10.4.2.0 |
| `org.apache.derby:derby` | Maven | From 10.1.2.1 | 10.4.2.0 |

Products: Apache Derby.

## How do I fix CVE-2010-2232?

Upgrade org.apache.derby:derby to 10.4.2.0 or later.

## Is CVE-2010-2232 being exploited?

There is no known exploitation of CVE-2010-2232 in the wild and no public exploit code.

## Other vulnerabilities in Apache Derby

- [CVE-2022-46337](https://insights.sbomify.com/CVE-2022-46337/): Apache Derby: LDAP injection vulnerability in authenticator (critical 9.8)
- [CVE-2015-1832](https://insights.sbomify.com/CVE-2015-1832/): Improper Restriction of XML External Entity Reference in Apace Derby (critical 9.1)
- [CVE-2018-1313](https://insights.sbomify.com/CVE-2018-1313/): Improper Access Control in Apache Derby (medium 5.3)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)
- [CVE-2006-7216](https://insights.sbomify.com/CVE-2006-7216/): Missing authorization in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2232 and fix it if it is affected.

What it is: CVE-2010-2232 is a high-severity path traversal vulnerability in Apache Derby, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-2232 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected from 10.1.2.1; fixed in 10.4.2.0
- org.apache.derby:derby (Maven): affected from 10.1.2.1; fixed in 10.4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2232/ (Markdown: https://insights.sbomify.com/CVE-2010-2232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2232
- OSV: https://osv.dev/vulnerability/CVE-2010-2232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2232/
Summaries are generated and may contain mistakes; the official description above is the record.
