{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2235 in the wild and no public exploit code.","fix":"Upgrade cobbler to 2.0.7 or later.","what":"CVE-2010-2235 is a high-severity code injection vulnerability in n/a, published on 9 Dec 2010. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2010-2235 and fix it if it is affected.\n\nWhat it is: CVE-2010-2235 is a high-severity code injection vulnerability in n/a, published on 9 Dec 2010. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2010-2235 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 2.0.7\n- cobbler (PyPI): affected all versions; fixed in 2.0.7\n- cobbler (PyPI): affected all versions; fixed in 2.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2235/ (Markdown: https://insights.sbomify.com/CVE-2010-2235/index.md)","id":"CVE-2010-2235","markdown":"https://insights.sbomify.com/CVE-2010-2235/index.md","name":"CVE-2010-2235","record":{"aliases":["GHSA-jhm7-38xj-pvm8","PYSEC-2026-794","RHSA-2010:0775"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"high_privilege","summary":"Remote authenticated administrators can execute arbitrary code via crafted kickstart templates due to enabled Python execution in the Cheetah engine.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"michael_dehaan"}],"cvss":{"score":8.5,"severity":"high","source":"nvd","vector":"AV:N/AC:M/Au:S/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.","ecosystems":["PyPI","Red Hat:network_satellite:5.3::el4","Red Hat:network_satellite:5.3::el5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler is vulnerable to code injection","id":"CVE-2010-2235","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2010"},"n_packages":7,"n_references":3,"next":{"headline":"Command injection in n/a","id":"CVE-2010-2236"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.7"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-jhm7-38xj-pvm8"},{"ecosystem":"PyPI","fixed":["2.0.7"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-jhm7-38xj-pvm8"},{"ecosystem":"PyPI","fixed":["2.0.7"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-794"},{"ecosystem":"Red Hat:network_satellite:5.3::el4","fixed":["0:1.6.6-15.el4sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2010:0775"},{"ecosystem":"Red Hat:network_satellite:5.3::el4","fixed":["0:1.6.6-15.el4sat"],"introduced":["0"],"last_affected":[],"package":"cobbler-debuginfo","purl":"pkg:rpm/redhat/cobbler-debuginfo","source":"RHSA-2010:0775"},{"ecosystem":"Red Hat:network_satellite:5.3::el5","fixed":["0:1.6.6-15.el5sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2010:0775"},{"ecosystem":"Red Hat:network_satellite:5.3::el5","fixed":["0:1.6.6-15.el5sat"],"introduced":["0"],"last_affected":[],"package":"cobbler-debuginfo","purl":"pkg:rpm/redhat/cobbler-debuginfo","source":"RHSA-2010:0775"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2010-2234"},"products":["n/a"],"published":"2010-12-09","related":[{"cvss_score":9,"headline":"Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability","id":"CVE-2008-6954","kev_date_added":null,"published":"2009-08-12"},{"cvss_score":7.5,"headline":"Cobbler subject to Command Injection","id":"CVE-2012-2395","kev_date_added":null,"published":"2012-06-16"},{"cvss_score":7.5,"headline":"Hardcoded credentials in n/a","id":"CVE-2009-5021","kev_date_added":null,"published":"2010-12-09"},{"cvss_score":7.2,"headline":"Misconfiguration in n/a","id":"CVE-2010-4512","kev_date_added":null,"published":"2010-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote authenticated administrators can execute arbitrary code via crafted kickstart templates due to enabled Python execution in the Cheetah engine.","url":"https://insights.sbomify.com/CVE-2010-2235/"}