# CVE-2010-2235: Cobbler is vulnerable to code injection

> Remote authenticated administrators can execute arbitrary code via crafted kickstart templates due to enabled Python execution in the Cheetah engine.

- **Severity:** High 8.5 (`AV:N/AC:M/Au:S/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-jhm7-38xj-pvm8, PYSEC-2026-794, RHSA-2010:0775

## What is CVE-2010-2235?

CVE-2010-2235 is a high-severity code injection vulnerability in n/a, published on 9 Dec 2010. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

template_api.py in Cobbler before 2.0.7, as used in Red Hat Network Satellite Server and other products, does not disable the ability of the Cheetah template engine to execute Python statements contained in templates, which allows remote authenticated administrators to execute arbitrary code via a crafted kickstart template file, a different vulnerability than CVE-2008-6954.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2010-2235?

3 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 2.0.7 |
| `cobbler` | PyPI | All versions | 2.0.7 |
| `cobbler` | PyPI | All versions | 2.0.7 |
| `cobbler` | Red Hat:network_satellite:5.3::el4 | All versions | 0:1.6.6-15.el4sat |
| `cobbler-debuginfo` | Red Hat:network_satellite:5.3::el4 | All versions | 0:1.6.6-15.el4sat |
| `cobbler` | Red Hat:network_satellite:5.3::el5 | All versions | 0:1.6.6-15.el5sat |
| `cobbler-debuginfo` | Red Hat:network_satellite:5.3::el5 | All versions | 0:1.6.6-15.el5sat |

Products: Michael Dehaan Cobbler.

## How do I fix CVE-2010-2235?

Upgrade cobbler to 2.0.7 or later.

## Is CVE-2010-2235 being exploited?

There is no known exploitation of CVE-2010-2235 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-6954](https://insights.sbomify.com/CVE-2008-6954/): Cobbler Web Interface Kickstart Template Remote Privilege Escalation Vulnerability (critical 9.0)
- [CVE-2012-2395](https://insights.sbomify.com/CVE-2012-2395/): Cobbler subject to Command Injection (high 7.5)
- [CVE-2009-5021](https://insights.sbomify.com/CVE-2009-5021/): Hardcoded credentials in n/a (high 7.5)
- [CVE-2010-4512](https://insights.sbomify.com/CVE-2010-4512/): Misconfiguration in n/a (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2235 and fix it if it is affected.

What it is: CVE-2010-2235 is a high-severity code injection vulnerability in n/a, published on 9 Dec 2010. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-2235 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 2.0.7
- cobbler (PyPI): affected all versions; fixed in 2.0.7
- cobbler (PyPI): affected all versions; fixed in 2.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2235/ (Markdown: https://insights.sbomify.com/CVE-2010-2235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2235
- OSV: https://osv.dev/vulnerability/CVE-2010-2235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2235/
Summaries are generated and may contain mistakes; the official description above is the record.
