CVE-2010-2273 Cross-Site Scripting in dojo
Remote attackers can inject arbitrary web script or HTML via unspecified vectors in the Dojo JavaScript library, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-2273?
CVE-2010-2273 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Jun 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in Dojo 1.0.x before 1.0.3, 1.1.x before 1.1.2, 1.2.x before 1.2.4, 1.3.x before 1.3.3, and 1.4.x before 1.4.2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, possibly related to dojo/resources/iframe_history.html, dojox/av/FLAudio.js, dojox/av/FLVideo.js, dojox/av/resources/audio.swf, dojox/av/resources/video.swf, util/buildscripts/jslib/build.js, and util/buildscripts/jslib/buildUtil.js, as demonstrated by the (1) dojoUrl and (2) testUrl parameters to util/doh/runner.html.
Weakness: CWE-79
Which versions are affected by CVE-2010-2273?
8 open source packages ship an affected version, including dojo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
dojo npm | From 1.10.0 | 1.10.10 |
dojo npm | From 1.10.0 | 1.10.10 |
dojo npm | From 1.11.0 | 1.11.6 |
dojo npm | From 1.11.0 | 1.11.6 |
dojo npm | From 1.12.0 | 1.12.4 |
dojo npm | From 1.12.0 | 1.12.4 |
2 more packages
dojo npm | From 1.13.0 | 1.13.1 |
dojo npm | From 1.13.0 | 1.13.1 |
Products include Dojotoolkit Dojo.
How do I fix CVE-2010-2273?
Upgrade dojo to a fixed version for your release line: 1.10.10, 1.11.6, 1.12.4 or 1.13.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-2273 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-2273 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2010-2273, GHSA-536q-8gxx-m782.