# CVE-2010-2273: Cross-Site Scripting in dojo

> Remote attackers can inject arbitrary web script or HTML via unspecified vectors in the Dojo JavaScript library, potentially leading to code execution.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jun 2010
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2010-2273, GHSA-536q-8gxx-m782

## What is CVE-2010-2273?

CVE-2010-2273 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Jun 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Dojo 1.0.x before 1.0.3, 1.1.x before 1.1.2, 1.2.x before 1.2.4, 1.3.x before 1.3.3, and 1.4.x before 1.4.2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, possibly related to dojo/resources/iframe_history.html, dojox/av/FLAudio.js, dojox/av/FLVideo.js, dojox/av/resources/audio.swf, dojox/av/resources/video.swf, util/buildscripts/jslib/build.js, and util/buildscripts/jslib/buildUtil.js, as demonstrated by the (1) dojoUrl and (2) testUrl parameters to util/doh/runner.html.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-2273?

8 open source packages ship an affected version, including dojo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dojo` | npm | From 1.10.0 | 1.10.10 |
| `dojo` | npm | From 1.10.0 | 1.10.10 |
| `dojo` | npm | From 1.11.0 | 1.11.6 |
| `dojo` | npm | From 1.11.0 | 1.11.6 |
| `dojo` | npm | From 1.12.0 | 1.12.4 |
| `dojo` | npm | From 1.12.0 | 1.12.4 |
| `dojo` | npm | From 1.13.0 | 1.13.1 |
| `dojo` | npm | From 1.13.0 | 1.13.1 |

Products: Dojotoolkit Dojo.

## How do I fix CVE-2010-2273?

Upgrade dojo to a fixed version for your release line: 1.10.10, 1.11.6, 1.12.4 or 1.13.1.

## Is CVE-2010-2273 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-2273 exists.

Public exploit code:

- Dojo Toolkit 1.4.1 - '/doh/runner.html' Multiple Cross-Site Scripting Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2010-2272](https://insights.sbomify.com/CVE-2010-2272/): Other in n/a (critical 10.0)
- [CVE-2010-2276](https://insights.sbomify.com/CVE-2010-2276/): Misconfiguration in n/a (critical 10.0)
- [CVE-2018-1000665](https://insights.sbomify.com/CVE-2018-1000665/): Improper Neutralization of Input During Web Page Generation in Dojo Dojo Objective Harness (medium 6.1)
- [CVE-2018-6561](https://insights.sbomify.com/CVE-2018-6561/): dijit editor cross-site scripting vulnerability (medium 6.1)
- [CVE-2015-5654](https://insights.sbomify.com/CVE-2015-5654/): Cross-Site Scripting in dojo (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2273 and fix it if it is affected.

What it is: CVE-2010-2273 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Jun 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2010-2273 exists.

Affected packages and fixed versions:
- dojo (npm): affected from 1.10.0; fixed in 1.10.10
- dojo (npm): affected from 1.10.0; fixed in 1.10.10
- dojo (npm): affected from 1.11.0; fixed in 1.11.6
- dojo (npm): affected from 1.11.0; fixed in 1.11.6
- dojo (npm): affected from 1.12.0; fixed in 1.12.4
- dojo (npm): affected from 1.12.0; fixed in 1.12.4
- dojo (npm): affected from 1.13.0; fixed in 1.13.1
- dojo (npm): affected from 1.13.0; fixed in 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2273/ (Markdown: https://insights.sbomify.com/CVE-2010-2273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2273
- OSV: https://osv.dev/vulnerability/CVE-2010-2273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2273/
Summaries are generated and may contain mistakes; the official description above is the record.
