CVE-2010-2422 Plone Cross-site Scripting vulnerability in PortalTransforms
Remote attackers can inject arbitrary web script or HTML via the safe_html transform in Plone, requiring user interaction to execute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-2422?
CVE-2010-2422 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 23 Jun 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in PortalTransforms in Plone 2.1 through 3.3.4 before hotfix 20100612 allows remote attackers to inject arbitrary web script or HTML via the safe_html transform.
Weakness: CWE-79
Which versions are affected by CVE-2010-2422?
3 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | All versions | 3.3.5 |
plone PyPI | From 2.1 | 3.3.6 |
Plone PyPI | From 2.1 | 3.3.6 |
Products include Plone Plone.
How do I fix CVE-2010-2422?
Upgrade plone to a fixed version for your release line: 3.3.5 or 3.3.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-2422 being exploited?
There is no known exploitation of CVE-2010-2422 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-qj7x-wm9q-qjx8, PYSEC-2010-19.