{"answers":{"affected":"3 open source packages ship an affected version, including paste. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2477 in the wild and no public exploit code.","fix":"Upgrade paste to 1.7.4 or later.","what":"CVE-2010-2477 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Nov 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2477 and fix it if it is affected.\n\nWhat it is: CVE-2010-2477 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Nov 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2477 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paste (PyPI): affected all versions; fixed in 1.7.4\n- paste (PyPI): affected all versions; fixed in 1.7.4\n- paste (PyPI): affected all versions; fixed in 1.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2477/ (Markdown: https://insights.sbomify.com/CVE-2010-2477/index.md)","id":"CVE-2010-2477","markdown":"https://insights.sbomify.com/CVE-2010-2477/index.md","name":"CVE-2010-2477","record":{"aliases":["DEBIAN-CVE-2010-2477","GHSA-7gfc-2v6g-6w9f","PYSEC-2010-29"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted 404 status codes in the Paste library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"paste","vendor":"pythonpaste"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the paste.httpexceptions implementation in Paste before 1.7.4 allow remote attackers to inject arbitrary web script or HTML via vectors involving a 404 status code, related to (1) paste.urlparser.StaticURLParser, (2) paste.urlparser.PkgResourcesParser, (3) paste.urlmap.URLMap, and (4) HTTPNotFound.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paste is vulnerable to Cross-site Scripting via vectors involving a 404 status code","id":"CVE-2010-2477","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":3,"n_references":9,"next":{"headline":"Integer overflow in n/a","id":"CVE-2010-2478"},"packages":[{"ecosystem":"PyPI","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"paste","purl":null,"source":"GHSA-7gfc-2v6g-6w9f"},{"ecosystem":"PyPI","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"paste","purl":"pkg:pypi/paste","source":"GHSA-7gfc-2v6g-6w9f"},{"ecosystem":"PyPI","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"paste","purl":"pkg:pypi/paste","source":"PYSEC-2010-29"}],"prev":{"headline":"Path traversal in syscp","id":"CVE-2010-2476"},"products":["n/a"],"published":"2010-11-05","related":[{"cvss_score":5.1,"headline":"Paste Script has improper group memberships permissions","id":"CVE-2012-0878","kev_date_added":null,"published":"2012-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted 404 status codes in the Paste library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2010-2477/"}