{"answers":{"affected":"3 open source packages ship an affected version, including mako. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2480 in the wild and no public exploit code.","fix":"Upgrade mako to 0.3.4 or later.","what":"CVE-2010-2480 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jul 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2480 and fix it if it is affected.\n\nWhat it is: CVE-2010-2480 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jul 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2480 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mako (PyPI): affected all versions; fixed in 0.3.4\n- mako (PyPI): affected all versions; fixed in 0.3.4\n- mako (PyPI): affected all versions; fixed in 0.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2480/ (Markdown: https://insights.sbomify.com/CVE-2010-2480/index.md)","id":"CVE-2010-2480","markdown":"https://insights.sbomify.com/CVE-2010-2480/index.md","name":"CVE-2010-2480","record":{"aliases":["DEBIAN-CVE-2010-2480","GHSA-7q8x-38mc-p84f","PYSEC-2010-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python templating library","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts in user browsers via XSS due to insufficient escaping in the Mako templating library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"mako","vendor":"makotemplates"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mako before 0.3.4 relies on the cgi.escape function in the Python standard library for cross-site scripting (XSS) protection, which makes it easier for remote attackers to conduct XSS attacks via vectors involving single-quote characters and a JavaScript onLoad event handler for a BODY element.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mako contains Cross-site Scripting vulnerability","id":"CVE-2010-2480","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":3,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2010-2481"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"mako","purl":null,"source":"GHSA-7q8x-38mc-p84f"},{"ecosystem":"PyPI","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"mako","purl":"pkg:pypi/mako","source":"GHSA-7q8x-38mc-p84f"},{"ecosystem":"PyPI","fixed":["0.3.4"],"introduced":["0"],"last_affected":[],"package":"mako","purl":"pkg:pypi/mako","source":"PYSEC-2010-1"}],"prev":{"headline":"HTML Purifier Cross-site Scripting (XSS) vulnerability","id":"CVE-2010-2479"},"products":["n/a"],"published":"2010-07-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts in user browsers via XSS due to insufficient escaping in the Mako templating library.","url":"https://insights.sbomify.com/CVE-2010-2480/"}