CVE-2010-2487 MoinMoin Cross-site Scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2010-2487?
CVE-2010-2487 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, 1.8.x before 1.8.8, and 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) Page.py, (2) PageEditor.py, (3) PageGraphicalEditor.py, (4) action/CopyPage.py, (5) action/Load.py, (6) action/RenamePage.py, (7) action/backup.py, (8) action/login.py, (9) action/newaccount.py, and (10) action/recoverpass.py.
Weakness: CWE-79
Which versions are affected by CVE-2010-2487?
7 open source packages ship an affected version, including moin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moin PyPI | All versions to 1.7.3 | None |
moin PyPI | All versions to 1.7.3 | None |
moin PyPI | From 1.8 | 1.8.8, 1.9.3 |
moin PyPI | From 1.8.0 | 1.8.8 |
moin PyPI | From 1.8.0 | 1.8.8 |
moin PyPI | From 1.9.0 | 1.9.3 |
1 more packages
moin PyPI | From 1.9.0 | 1.9.3 |
Products include Moinmo Moinmoin.
How do I fix CVE-2010-2487?
Upgrade moin to a fixed version for your release line: 1.8.8 or 1.9.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-2487 being exploited?
There is no known exploitation of CVE-2010-2487 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-15275 malicious SVG attachment causing stored XSS vulnerability in MoinMoin
- CVE-2009-4762 MoinMoin Improper Access Control vulnerability
- CVE-2010-0669 MoinMoin improper sanitizes user profiles
- CVE-2010-0717 MoinMoin has improper default configuration
- CVE-2010-0668 MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration
Sources
Also known as DSA-2083-1, GHSA-5m2m-27cg-7v4v, PYSEC-2010-16.