{"answers":{"affected":"7 open source packages ship an affected version, including moin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2487 in the wild and no public exploit code.","fix":"Upgrade moin to a fixed version for your release line: 1.8.8 or 1.9.3.","what":"CVE-2010-2487 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2487 and fix it if it is affected.\n\nWhat it is: CVE-2010-2487 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2487 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected all versions up to 1.7.3; no fix listed\n- moin (PyPI): affected all versions up to 1.7.3; no fix listed\n- moin (PyPI): affected from 1.8; fixed in 1.8.8, 1.9.3\n- moin (PyPI): affected from 1.8.0; fixed in 1.8.8\n- moin (PyPI): affected from 1.8.0; fixed in 1.8.8\n- moin (PyPI): affected from 1.9.0; fixed in 1.9.3\n- moin (PyPI): affected from 1.9.0; fixed in 1.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2487/ (Markdown: https://insights.sbomify.com/CVE-2010-2487/index.md)","id":"CVE-2010-2487","markdown":"https://insights.sbomify.com/CVE-2010-2487/index.md","name":"CVE-2010-2487","record":{"aliases":["DSA-2083-1","GHSA-5m2m-27cg-7v4v","PYSEC-2010-16"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"MoinMoin Wiki","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moinmoin","vendor":"moinmo"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, 1.8.x before 1.8.8, and 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) Page.py, (2) PageEditor.py, (3) PageGraphicalEditor.py, (4) action/CopyPage.py, (5) action/Load.py, (6) action/RenamePage.py, (7) action/backup.py, (8) action/login.py, (9) action/newaccount.py, and (10) action/recoverpass.py.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MoinMoin Cross-site Scripting (XSS) vulnerability","id":"CVE-2010-2487","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":7,"n_references":17,"next":{"headline":"Null dereference in znc","id":"CVE-2010-2488"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.7.3"],"package":"moin","purl":null,"source":"GHSA-5m2m-27cg-7v4v"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["1.7.3"],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-5m2m-27cg-7v4v"},{"ecosystem":"PyPI","fixed":["1.8.8","1.9.3"],"introduced":["1.8","1.9"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2010-16"},{"ecosystem":"PyPI","fixed":["1.8.8"],"introduced":["1.8.0"],"last_affected":[],"package":"moin","purl":null,"source":"GHSA-5m2m-27cg-7v4v"},{"ecosystem":"PyPI","fixed":["1.8.8"],"introduced":["1.8.0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-5m2m-27cg-7v4v"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["1.9.0"],"last_affected":[],"package":"moin","purl":null,"source":"GHSA-5m2m-27cg-7v4v"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["1.9.0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-5m2m-27cg-7v4v"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2010-2486"},"products":["n/a"],"published":"2010-08-04","related":[{"cvss_score":8.7,"headline":"malicious SVG attachment causing stored XSS vulnerability in MoinMoin","id":"CVE-2020-15275","kev_date_added":null,"published":"2020-11-11"},{"cvss_score":7.5,"headline":"MoinMoin Improper Access Control vulnerability","id":"CVE-2009-4762","kev_date_added":null,"published":"2010-03-29"},{"cvss_score":7.5,"headline":"MoinMoin improper sanitizes user profiles","id":"CVE-2010-0669","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":7.5,"headline":"MoinMoin has improper default configuration","id":"CVE-2010-0717","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration","id":"CVE-2010-0668","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin Access Restrictions Bypassed due to improper ACL enforcement","id":"CVE-2008-6603","kev_date_added":null,"published":"2009-04-03"},{"cvss_score":6.4,"headline":"MoinMoin Directory Traversal vulnerability","id":"CVE-2012-6080","kev_date_added":null,"published":"2013-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2010-2487/"}