# CVE-2010-2487: MoinMoin Cross-site Scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2010
- **Updated:** 7 Aug 2024
- **Also known as:** DSA-2083-1, GHSA-5m2m-27cg-7v4v, PYSEC-2010-16

## What is CVE-2010-2487?

CVE-2010-2487 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, 1.8.x before 1.8.8, and 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) Page.py, (2) PageEditor.py, (3) PageGraphicalEditor.py, (4) action/CopyPage.py, (5) action/Load.py, (6) action/RenamePage.py, (7) action/backup.py, (8) action/login.py, (9) action/newaccount.py, and (10) action/recoverpass.py.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-2487?

7 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions to 1.7.3 | None |
| `moin` | PyPI | All versions to 1.7.3 | None |
| `moin` | PyPI | From 1.8 | 1.8.8, 1.9.3 |
| `moin` | PyPI | From 1.8.0 | 1.8.8 |
| `moin` | PyPI | From 1.8.0 | 1.8.8 |
| `moin` | PyPI | From 1.9.0 | 1.9.3 |
| `moin` | PyPI | From 1.9.0 | 1.9.3 |

Products: Moinmo Moinmoin.

## How do I fix CVE-2010-2487?

Upgrade moin to a fixed version for your release line: 1.8.8 or 1.9.3.

## Is CVE-2010-2487 being exploited?

There is no known exploitation of CVE-2010-2487 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15275](https://insights.sbomify.com/CVE-2020-15275/): malicious SVG attachment causing stored XSS vulnerability in MoinMoin (high 8.7)
- [CVE-2009-4762](https://insights.sbomify.com/CVE-2009-4762/): MoinMoin Improper Access Control vulnerability (high 7.5)
- [CVE-2010-0669](https://insights.sbomify.com/CVE-2010-0669/): MoinMoin improper sanitizes user profiles (high 7.5)
- [CVE-2010-0717](https://insights.sbomify.com/CVE-2010-0717/): MoinMoin has improper default configuration (high 7.5)
- [CVE-2010-0668](https://insights.sbomify.com/CVE-2010-0668/): MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-2487 and fix it if it is affected.

What it is: CVE-2010-2487 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-2487 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions up to 1.7.3; no fix listed
- moin (PyPI): affected all versions up to 1.7.3; no fix listed
- moin (PyPI): affected from 1.8; fixed in 1.8.8, 1.9.3
- moin (PyPI): affected from 1.8.0; fixed in 1.8.8
- moin (PyPI): affected from 1.8.0; fixed in 1.8.8
- moin (PyPI): affected from 1.9.0; fixed in 1.9.3
- moin (PyPI): affected from 1.9.0; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-2487/ (Markdown: https://insights.sbomify.com/CVE-2010-2487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-2487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-2487
- OSV: https://osv.dev/vulnerability/CVE-2010-2487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-2487/
Summaries are generated and may contain mistakes; the official description above is the record.
