{"answers":{"affected":"3 open source packages ship an affected version, including roundup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2491 in the wild and no public exploit code.","fix":"Upgrade roundup to 1.4.14 or later.","what":"CVE-2010-2491 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Sep 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2491 and fix it if it is affected.\n\nWhat it is: CVE-2010-2491 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Sep 2010. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2491 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- roundup (PyPI): affected all versions; fixed in 1.4.14\n- roundup (PyPI): affected all versions; fixed in 1.4.14\n- roundup (PyPI): affected all versions; fixed in 1.4.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2491/ (Markdown: https://insights.sbomify.com/CVE-2010-2491/index.md)","id":"CVE-2010-2491","markdown":"https://insights.sbomify.com/CVE-2010-2491/index.md","name":"CVE-2010-2491","record":{"aliases":["GHSA-frgf-rv99-862x","PYSEC-2010-31"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Roundup issue tracker","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the template argument in the Roundup issue tracker.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"roundup","vendor":"roundup-tracker"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in cgi/client.py in Roundup before 1.4.14 allows remote attackers to inject arbitrary web script or HTML via the template argument to the /issue program.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Roundup Cross-site Scripting (XSS) vulnerability","id":"CVE-2010-2491","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":3,"n_references":14,"next":{"headline":"Memory corruption in n/a","id":"CVE-2010-2492"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.14"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":null,"source":"GHSA-frgf-rv99-862x"},{"ecosystem":"PyPI","fixed":["1.4.14"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"GHSA-frgf-rv99-862x"},{"ecosystem":"PyPI","fixed":["1.4.14"],"introduced":["0"],"last_affected":[],"package":"roundup","purl":"pkg:pypi/roundup","source":"PYSEC-2010-31"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2010-2490"},"products":["n/a"],"published":"2010-09-24","related":[{"cvss_score":6.4,"headline":"Roundup xml-rpc server improper check of property permissions","id":"CVE-2008-1475","kev_date_added":null,"published":"2008-03-24"},{"cvss_score":6.1,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39124","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":6.1,"headline":"Multiple cross-site scripting (XSS) vulnerabilities in Roundup","id":"CVE-2012-6133","kev_date_added":null,"published":"2020-01-30"},{"cvss_score":5.4,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39125","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5.4,"headline":"Roundup Cross-site Scripting Vulnerability","id":"CVE-2024-39126","kev_date_added":null,"published":"2024-07-17"},{"cvss_score":5,"headline":"Roundup Directory traversal vulnerability","id":"CVE-2004-1444","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":4.3,"headline":"Roundup Cross-site Scripting (XSS) vulnerability","id":"CVE-2012-6130","kev_date_added":null,"published":"2014-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the template argument in the Roundup issue tracker.","url":"https://insights.sbomify.com/CVE-2010-2491/"}