{"answers":{"affected":"3 open source packages ship an affected version, including moin and Moin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-2970 in the wild and no public exploit code.","fix":"Upgrade moin to 1.9.3 or later.","what":"CVE-2010-2970 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-2970 and fix it if it is affected.\n\nWhat it is: CVE-2010-2970 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Aug 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-2970 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected from 1.9; fixed in 1.9.3\n- moin (PyPI): affected from 1.9.0; fixed in 1.9.3\n- Moin (PyPI): affected from 1.9.0; fixed in 1.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-2970/ (Markdown: https://insights.sbomify.com/CVE-2010-2970/index.md)","id":"CVE-2010-2970","markdown":"https://insights.sbomify.com/CVE-2010-2970/index.md","name":"CVE-2010-2970","record":{"aliases":["GHSA-gxh5-r8gp-pjc3","PYSEC-2010-18"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MoinMoin Wiki","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially compromising user sessions or data integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moinmoin","vendor":"moinmo"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.9.x before 1.9.3 allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/SlideShow.py, (2) action/anywikidraw.py, and (3) action/language_setup.py, a similar issue to CVE-2010-2487.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MoinMoin cross-site scripting (XSS) vulnerability","id":"CVE-2010-2970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2010"},"n_packages":3,"n_references":13,"next":{"headline":"Memory corruption in n/a","id":"CVE-2010-2971"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["1.9.0"],"last_affected":[],"package":"Moin","purl":null,"source":"GHSA-gxh5-r8gp-pjc3"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["1.9"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2010-18"},{"ecosystem":"PyPI","fixed":["1.9.3"],"introduced":["1.9.0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-gxh5-r8gp-pjc3"}],"prev":{"headline":"MoinMoin cross-site scripting (XSS) vulnerability","id":"CVE-2010-2969"},"products":["n/a"],"published":"2010-08-04","related":[{"cvss_score":8.7,"headline":"malicious SVG attachment causing stored XSS vulnerability in MoinMoin","id":"CVE-2020-15275","kev_date_added":null,"published":"2020-11-11"},{"cvss_score":7.5,"headline":"MoinMoin Improper Access Control vulnerability","id":"CVE-2009-4762","kev_date_added":null,"published":"2010-03-29"},{"cvss_score":7.5,"headline":"MoinMoin improper sanitizes user profiles","id":"CVE-2010-0669","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":7.5,"headline":"MoinMoin has improper default configuration","id":"CVE-2010-0717","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration","id":"CVE-2010-0668","kev_date_added":null,"published":"2010-02-26"},{"cvss_score":6.8,"headline":"MoinMoin Access Restrictions Bypassed due to improper ACL enforcement","id":"CVE-2008-6603","kev_date_added":null,"published":"2009-04-03"},{"cvss_score":6.4,"headline":"MoinMoin Directory Traversal vulnerability","id":"CVE-2012-6080","kev_date_added":null,"published":"2013-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki pages, potentially compromising user sessions or data integrity.","url":"https://insights.sbomify.com/CVE-2010-2970/"}