{"answers":{"affected":"2 open source packages ship an affected version, including drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2010-3094 in the wild and no public exploit code.","fix":"Upgrade drupal/drupal to 6.18 or later.","what":"CVE-2010-3094 is a low-severity cross-site scripting vulnerability in Drupal Drupal, published on 21 Sep 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2010-3094 and fix it if it is affected.\n\nWhat it is: CVE-2010-3094 is a low-severity cross-site scripting vulnerability in Drupal Drupal, published on 21 Sep 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2010-3094 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/drupal (Packagist): affected from 6.0; fixed in 6.18\n- drupal/drupal (Packagist): affected from 6.0; fixed in 6.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2010-3094/ (Markdown: https://insights.sbomify.com/CVE-2010-3094/index.md)","id":"CVE-2010-3094","markdown":"https://insights.sbomify.com/CVE-2010-3094/index.md","name":"CVE-2010-3094","record":{"aliases":["GHSA-pjmx-4gc6-hwv8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal CMS","requires_auth":"low_privilege","summary":"Authenticated users can inject scripts via actions or content, potentially leading to code execution or account takeover in Drupal.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:N/AC:H/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal cross-site scripting vulnerability via actions feature and trigger module","id":"CVE-2010-3094","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"xss","year":"2010"},"n_packages":2,"n_references":5,"next":{"headline":"Path traversal in mailscanner","id":"CVE-2010-3095"},"packages":[{"ecosystem":"Packagist","fixed":["6.18"],"introduced":["6.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-pjmx-4gc6-hwv8"},{"ecosystem":"Packagist","fixed":["6.18"],"introduced":["6.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-pjmx-4gc6-hwv8"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2010-3093"},"products":["n/a"],"published":"2010-09-21","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Authenticated users can inject scripts via actions or content, potentially leading to code execution or account takeover in Drupal.","url":"https://insights.sbomify.com/CVE-2010-3094/"}