# CVE-2010-3094: Drupal cross-site scripting vulnerability via actions feature and trigger module

> Authenticated users can inject scripts via actions or content, potentially leading to code execution or account takeover in Drupal.

- **Severity:** Low 2.1 (`AV:N/AC:H/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-pjmx-4gc6-hwv8

## What is CVE-2010-3094?

CVE-2010-3094 is a low-severity cross-site scripting vulnerability in Drupal Drupal, published on 21 Sep 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2010-3094?

2 open source packages ship an affected version, including drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/drupal` | Packagist | From 6.0 | 6.18 |
| `drupal/drupal` | Packagist | From 6.0 | 6.18 |

Products: Drupal Drupal.

## How do I fix CVE-2010-3094?

Upgrade drupal/drupal to 6.18 or later.

## Is CVE-2010-3094 being exploited?

There is no known exploitation of CVE-2010-3094 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-3094 and fix it if it is affected.

What it is: CVE-2010-3094 is a low-severity cross-site scripting vulnerability in Drupal Drupal, published on 21 Sep 2010. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2010-3094 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.18
- drupal/drupal (Packagist): affected from 6.0; fixed in 6.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-3094/ (Markdown: https://insights.sbomify.com/CVE-2010-3094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-3094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-3094
- OSV: https://osv.dev/vulnerability/CVE-2010-3094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-3094/
Summaries are generated and may contain mistakes; the official description above is the record.
