CVE-2010-3198 Zope Denial of Service (DoS) vulnerability in ZServer
Remote attackers can crash ZServer worker threads by triggering uncaught exceptions, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-3198?
CVE-2010-3198 is a medium-severity denial of service vulnerability in n/a, published on 8 Sep 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ZServer in Zope 2.10.x before 2.10.12 and 2.11.x before 2.11.7 allows remote attackers to cause a denial of service (crash of worker threads) via vectors that trigger uncaught exceptions.
Which versions are affected by CVE-2010-3198?
5 open source packages ship an affected version, including zope and Zope. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zope PyPI | From 2.10.0 | 2.10.12, 2.11.7 |
zope PyPI | From 2.10.0 | 2.10.12 |
zope PyPI | From 2.11.0 | 2.11.7 |
Zope PyPI | From 2.10.0 | 2.10.12 |
Zope PyPI | From 2.11.0 | 2.11.7 |
Products include Zope Zope.
How do I fix CVE-2010-3198?
Upgrade zope to a fixed version for your release line: 2.10.12 or 2.11.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2010-3198 being exploited?
There is no known exploitation of CVE-2010-3198 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2000-0062 Zope DTML implementation Improper Authentication
- CVE-2021-32674 Remote Code Execution via traversal in TAL expressions
- CVE-2000-1211 Zope does not properly perform security registration for legacy names
- CVE-2002-0170 Zope does not properly verify the access for objects with proxy roles
- CVE-2002-0688 ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions
Sources
Also known as GHSA-qh4q-fwf8-qqrw, PYSEC-2010-32.